kategorie:

menu:


Co mě dneska vyděsilo

22.02.2008   ::    téma: Linux

Dneska mi během rozhovoru přes Jabber poslal Morpheus jeden krásný zdroják. Prej ať jej zkompiluji a spustím. Proč ne, řekl jsem si. Spustím to pod uživatelem, který má práva omezena na minimum a uvidím…


(pokračování)

PHP5 společně s PHP4 na Apache2

15.02.2008   ::    téma: Linux

Mezi verzemi PHP jsou v některých směrech značné rozdíly. Často se tedy stává, že kód odladěný na PHP5 při nasazení na serveru s PHP4 hází errory a je nutné jej pracně přepisovat. V tomto zápisku popíši jak nastavit pro některé virtuální servery PHP4 a pro ostatní virtuální servery PHP5. Standartně není možné nainstalovat obě verze php jako moduly, protože balíčky libapache2-mod-php5libapache2-mod-php4 spolu kolidují. Proto je nutné nainstalovat jednu verzi jako cgi. Spouštění PHP jako CGI má určité nevýhody, například není možné používat sessions a provádění scriptů je pomalejší. Proto tento postup je vhodný spíše na testovací (lokální) servery v kombinaci s aplikacemi, kde php jako cgi nevadí.


(pokračování)